Windows 10 Git for Windows installation ... issue

First of all … I much appreciate the step by step directions for installing VMware and Vagrant here - ht tps://learn.userfrosting. com/installation/environment/homestead This level of step by step is great for learning and new… I will say i ran into a few… hickups before finally getting this installed and working right.

The First being after the ‘installation’ i got the ‘no input file specified’ and the ‘An exception has been thrown’ result… Thats because i wasn’t aware it didn’t fully properly install… The code completed and said UserFrosting Installed go to .A mention to that error somewhere on the install page to the troubleshooting step (h ttps://learn. userfrosting. com/troubleshooting/common-problems) in these installation steps would be helpful…

Second… I narrowed it down to -> ```
EPROTO: protocol error, symlink ‘…/acorn/bin/acorn’
Error… which led me on a wild chase of various githubs and stack overflow. I was in fact using git for windows in administrator mode, but it didn’t matter. npm install was the issue no matter what I did. Changing the code manually (in the node_modules/ache/esm/randomnumber.js) to use “npm install --no-bin-links” instead of “npm install” in the file… fixed it…

Then another error later on… same issue… changing that file(BuildAssets.php) to npm install --no-bin-links… again fixed it…

I followed every single instruction in the install steps and still spent way too much time trying to figure out why these errors were happening when the install file makes it seem like click click done.

I even went to laravel homestead page and tried this option with no luck…
h ttps://laravel. co m/docs/5.8/homestead#provider-specific-settings

This response on github suggests “That’s not necessary.
On Windows, run Command Prompt as administrator will solve all our problems.”

But… the tutorial is suggesting using git for windows as your command prompt…and ssh… even as Administrator… It wont work.There is confusion.

Perhaps other windows 10 users having the same issue… so I wanted to post it somewhere and give feedback that perhaps it could/should be mentioned. Windows 10… it’s a hard life.