Unable to set a user's password


#1

I thought I’ve done this before but it doesn’t seem to work (using v4.1.16-alpha).
I created a user and then tried to set the password manually. The request is a PUT
to route /api/users/u/jose.v/password and it returns a 404. I don’t understand why
it returns a 404 since there is a route in sprinkles/admin/routes/users.php (line 38):
$this->put(’/u/{user_name}/{field}’, ‘UserFrosting\Sprinkle\Admin\Controller\UserController:updateField’);
I’ve checked that this is not invoked.


#2

Is this happening with UF’s built-in interface? Or are you issuing the request in your own code?


#3

I was able to reproduce this with an unmodified UserFrosting from the repo with sprinkles extend-user and pastries.
So, I then tried to modifying the ‘City’ field and got the same error; I tried changing the first_name field and got the same error. Now I’m suspicious because I’ve changed these fields before.


#4

Permission issue ?


#5

I’m still trying to figure out what happened but I had to delete the database and start over.
Now everything is working fine.