Installation Errors v4.3.3 and Homestead v9.3.0

I’ve been trying for several hours to get a new installation up using various combinations of UserFrosting and Homestead and can’t seem to get it to work. It is either telling me the Node version is incorrect (has to be above 6 for all versions below 4.3.3 which needs 10.12) of it is failing to install several of the vendor packages with CRC check failures. Currently I am getting the message:
[ERROR] UserFrosting requires Node version v10.12.0 or above. Check the documentation for more details.
But when I try to install or update node it says:
nodejs is already the newest version (12.16.1-1nodesource1).

I am using virtual box on a new Windows 10 installation. Any help would be appreciated.

The version the package manager reports may not be the version UF sees. What does node --version return in the console?

It has been giving different results pretty much each time…a few times was a segmentation fault, a fews times it couldn’t find it, i tried one last time before calling it a night and now it shows that is has version 12.16.1 and is giving a different error:

userfrosting: ERR! Unexpected token
in JSON at position 6605 while parsing near ‘…0.3",“source”:">=�z
����s\�l[�i{":">=1…’
userfrosting: npm
userfrosting:
userfrosting: ERR! A complete log of this run can be found in:
userfrosting: npm ERR! /root/.npm/_logs/2020-03-09T05_04_11_792Z-debug.log
userfrosting:
userfrosting: [ERROR] npm dependency installation has failed

And this is the content of the log file

0 info it worked if it ends with ok
1 verbose cli [ '/usr/local/bin/node', '/usr/local/bin/npm', 'clean-install' ]
2 info using [email protected]
3 info using [email protected]
4 verbose config Skipping project config: /home/vagrant/.npmrc. (matches userconfig)
5 verbose npm-session 9bf46bf6d2f252a1
6 info prepare initializing installer
7 verbose prepare starting workers
8 verbose prepare installation prefix: /home/vagrant
9 verbose teardown shutting down workers.
10 info teardown Done in 0s
11 verbose stack Error: ENOENT: no such file or directory, open '/home/vagrant/package.json'
12 verbose cwd /home/vagrant
13 verbose Linux 4.15.0-88-generic
14 verbose argv "/usr/local/bin/node" "/usr/local/bin/npm" "clean-install"
15 verbose node v12.16.1
16 verbose npm  v6.13.4
17 error code ENOENT
18 error syscall open
19 error path /home/vagrant/package.json
20 error errno -2
21 error enoent ENOENT: no such file or directory, open '/home/vagrant/package.json'
22 error enoent This is related to npm not being able to find a file.
23 verbose exit [ -2, true ]

So one thing I noticed is that no matter which version of homestead I download, the “install” script always says checking to make sure version 9.3.0 is up to date. Is there any way to stop it from using the newest version of homestead? This seems to cause the error, unable to find Slim\Container, on the 4.2.x branch of UserFrosting and the initial setup fails to complete.

This can be closed. After several attempts and runs at the bake command, i got it up and running.

1 Like

Sounds like the issue might have been related to conflicting installs of node, certainly wouldn’t be the first time. I’ve been bitten by this in the past. Regardless, glad to hear the issue is resolved.