Insecure Connection in FireFox Developer Edition - Solved


#1

When I try to bring up the UF login ( https://userfrosting.app/ ) I get this:

Your connection is not secure

The owner of userfrosting.app has configured their website improperly. To protect your information from being stolen, Firefox Developer Edition has not connected to this website.

This site uses HTTP Strict Transport Security (HSTS) to specify that Firefox Developer Edition may only connect to it securely. As a result, it is not possible to add an exception for this certificate.

This does not happen with plain Firefox.

-Mike


#2

Google bought the .app TLD. http://www.bbc.com/news/technology-31659666

Likely what’s happened is they have made HTTPS mandatory, meaning browsers will automatically redirect from HTTP to HTTPS regardless of site specific settings.

Same goes for .dev. https://www.theregister.co.uk/2015/03/13/google_developer_gtld_domain_icann/

As an alternative, during development you should use .localhost or .test, as they are reserved have been reserved specifically for use in a local context (such as testing). https://tools.ietf.org/html/rfc2606


#3

I see the Userfrosting Installation Instructions have been modified to use http://userfrosting.test, instead of https://userfrosting.app/. So I will have to modify my Homestead.yaml file to:

sites:
- map: userfrosting.test
to: /home/vagrant/userfrosting/public

Then I have to modify my hosts file to:

192.168.10.10 userfrosting.test

Next, point my browser to:

http://userfrosting.test


#4

Almost working. Unfortunately all of my links have https://userfrosting.app. For example, when I click on ‘About’ the link goes to ‘https://userfrosting.app/about’ , not http://userfrosting.test/about.

Is there another place besides the homestead.yaml and hosts file where I am supposed to modify userfrosting.app to userfrosting.test???

Thanks for your time,

-Mike


#5

Provisioning homestead fixed the last issue!!!

vagrant provision

Thanks to Alex Weissman!

-Mike