Http://localhost/~username/userfrosting/public/ WORKS, http://userfrosting.app DOES NOT - Solved!


#1

Hello,

Brand new to Userfrosting. Install is almost complete. If I try to visit my Userfrosting site by entering:

http://localhost/~username/userfrosting/public/

I get the expected page. But if I try

http://userfrosting.app

I get the following error:

Twig_Error_Runtime
An exception has been thrown during the rendering of a template (“SQLSTATE[HY000] [1045] Access denied for user ‘userfrosting’@‘localhost’ (using password: YES)”).

I have a local MySQL install that has the userfrosting migrations completed, so I am confused.

Any help is much appreciated, thanks in advance.

Mike


#2

Hi @mleary2001

Sounds like you may have mixed up a development environment for a different one.

Can you outline your current setup, and what steps you took to install UF?


#3

Thank you for your quick reply Josh!

I think I completed a native install while trying a homestead install of Userfrosting. Using Sequel Pro I have a userfrosting user and a userfrosting database with the completed migrations tables. In my native command line I can run ‘vagrant up’ and ‘vagrant ssh’.

On my homestead CLI I can cd into the userfrosting directory that is linked to my native userfrosting directory and I can run ">mysql ‘SHOW DATABASES’ which returns the empty set.

Question: On the page

https://learn.userfrosting.com/installation/environment/homestead

After the reader is asked to run ‘vagrant ssh’ on the native CLI, is the rest of the install conducted in the homestead CLI, or the native CLI??? In what CLI are the following commands executed:

cd userfrosting
composer install

Thanks in advance for your time,

Mike


#4

Update.

In my homestead.yaml file I changed

databases:
    - homestead

to

databases:
    - userfrosting

After a complete reboot I next typed vagrant ssh’. In my homestead CLI I can see these databases

+--------------------+
| Database           |
+--------------------+
| information_schema |
| homestead          |
| mysql              |
| performance_schema |
| sys                |
| userfrosting       |
+--------------------+

But the userfrosting database in homestead has no tables, while the native userfrosting database has lots of tables. I still get an error when loading http://userfrosting.app:

Access denied for user ‘userfrosting’@‘localhost’ (using password: YES)


#5

Ah, yes, you’ll need to run bakery in the virtual machine. The vagrant VM has its own instance of MySQL, so you’ll need to run Bakery in the VM so it connects to the VM’s instance of MySQL, rather than connecting to your native environment’s instance.


#6

That fixed it. Now onto the next snag. Thanks!