Help with Styling after Homestead Installation


#1

Hello,

I am new at frameworks and by far this is the best framework I have encountered and my professor highly recommends it. I went through the steps for the Homestead installation. However, when I go to http://userfrosting.test/ there is no styling. I most have done something wrong in the process. Any suggestions on how to fix?

Thank you!


#2

Hi
There are a few reasons you might not have styling. The most common been to do with the rewrite module not been enabled or the htaccess been disabled. if its either of thees two, the links won’t work either.
If the the links do work however, then check that npm has ran successfully and installed or the assests. These should be located in the SPRINKLE_NAME/assets/vendor directory.


#3

Hello,
Thank you for your response. The links are working and it seems that npm has ran successfully. I tried building the assets again with php bakery build-assets -f, but the styling still doesn’t show up. Do you think I should try to restart?


#4

@abdullah.seba, Homestead should be using nginx, not Apache, so there is no .htaccess.

I believe I’ve seen some other reports of this problem in chat. My guess is that this is a problem with the way nginx is configured in recent versions of Homestead. @kjc10, do other pages (when you click a link) fail to load as well?


#5

Ah, I missed the Homestead bit. I’ve had enough of Homestead for one day :fu:


#6

The other links also fail when I click them. The only ones that seems to work is the links that are linked to a web address like the userfrosting website. But when I click on about it rederictes me to homestead.test and the homestead.test’s server IP address can’t be found.


#7

After your question, I figured out that I messed up Homestead.yaml
I did not save the changes:
- map: userfrosting.test
to: /home/vagrant/userfrosting/public
Thank you @abdullah.seba and @alexweissman for your help!