Debug the Login Process?


#1

When I try logging in, the login page remains and there are no user messages displayed. Its the same behavior whether I use the right login credentials or intentionally use bad credentials.

Where on the filesystem might I find some helpful debugging information to track down the root cause of this breakage? The apache error.log shows nothing.

Here are some observations …

  1. In the browser (firefox) in the network tab I see a POST with status 400 and a GET with status 200 every time I click the “Login” button.

  2. I don’t see any new records in the activities and sessions tables of the database


#2

Just an update: This is ONLY happening with my firefox browser — the chrome browser is logging in just fine.

After that experience, I tried logging in with firefox using the “Private Browsing” mode and that worked.

Any thoughts on how to debug this or what would cause this? A bad cookie?

My setup:

  • Linux Ubuntu 18 VM
  • Running Userfrosting in Docker stacks

#3

Clearing the web cache and clearing the cookie cache did not fix the issue. However, rebooting my VM did. Any thoughts on what might have been at the root?


#4

Probably a bad session. No error message indicate It might be related to the sessions, as those are store in the session by default. Restarting the web server should fix session error.

It’s the first time I hear about this, if you get it again, it might be worth exploring if it’s a larger issue. You can also switch to cache storage for alerts if it appear again.


#5

Thanks for the response @Malou, I think you are onto something with the session insight. Here is some more info…

  1. My environment is a VM that I pause for days at a time. I paused it last week after logging in. Today, same symptoms as before — cannot login and there are no messages.
  2. I restarted apache webserver — did not fix the problem.
  3. I then removed all files from the app/sessions folder — problem fixed.

Is there a place where we can enhance the login code to detect the old/stale session file and remove it automatically to prevent this?


#6

Hi @Malou – do do I do this …

The login issue happened again to me today, was logging in fine all morning and now a few hours later I’m automatically logged out and login is not reporting errors and not showing messages on the screen. Like before, I removed all the contents of the app/sessions folder and was then able to login again.

Would like to find some insight on where this is breaking.